Alex's Personal Blog

News and updates for friends and family

Articles tagged with installation

World of Warcraft Installation Problems Solved

Posted: Sat, 03 Mar 2007 by

I've been playing the World of Warcraft off and on ever since it's release in November of 2004. In general I've been really happy with it. As with everything else that I do in my free time I would occasionally move on to other things and, especially owning my own house now, most of my free time has been filled with house "to-do's". After playing through a bit of several characters to about the level 20 point I would inevitably start a new character to try and experience what all the different race/class combinations had to offer. As I had played through most of them I was really stoked for the release of the first expansion for the game, the Burning Crusade. Come mid-January of this year I received my coveted Collector's Edition of the Burning Crusade and started the installation process as soon as I got home. One of the great things about the Collector's Edition is that it comes with both a CD and DVD version of the game (similarly to the original Collector's Edition) so I didn't need to put in a disk, wait 10-15 minutes and then swap it out for the next 4 times. Not exactly a thrilling time. Just pop in the DVD, let it do its thing and start playing soon after... or so I thought. When the installation finished I feverishly started up the game, tried to login and... it started downloading another patch. Okay, no big deal. It's pretty standard procedure for a new Blizzard game launch. I waited a few minutes for the patch to download, installed it and finally started the game again. Only this time, after putting in my login credentials I got an error saying "Unable to Validate Game Version" which had a reference to a support page. The page mentioned something about the possibility of a virus and suggested downloading and installing two different virus scanners to make sure all was well. I run an "always-on" virus scanner so I knew that wasn't the problem. It also said something about a custom UI possibly causing the problem. That I believed. I had tinkered with the WoW UI a bit so it wouldn't have surprised me. They referred to a repair utility which would go through and check all the files. Once I finished running the utility (about 30-40 minutes later) I tried to reconnect again but got the same error. At this point the page instructs you to uninstall everything and reinstall from scratch!!! This wouldn't have been so bad except that installing two DVD's worth of game files takes at least an hour. At that point you then need to wait for the game to be patched, etc, etc. I grudgingly removed all of WoW's files and started the installation process. Since my original WoW DVD has the original version of it I was afraid of needing to apply patches before reinstalling the Burning Crusade. Much to my delight I tried installing the expansion right after the original disk and it upgraded my installation to v2.0. That's about two Gigs worth of patches I didn't need to apply manually. Hoorah!I launched the game one last time, it patched itself and even after that I was able to login in. Success!!! Or so I thought. For the last several weeks I've been very distracted by the goings on in life and so haven't played WoW. I was excited this weekend to pick it up and start playing again. I launched the game, tried to login and, once again, got the same error, even after logging in successfully before. I couldn't believe it. All the time I spent reinstalling the game was all for nothing. Once again I uninstalled everything and reinstalled. Once again the game patched itself to v2.03 but this time when I tried to login again it gave me the same error... yes... again. Whoever wrote this auto patcher clearly didn't think about how many paying customers he was going to locking out with his incorrect logic. Rather than start all over again I decided to try something. The current version of WoW (at the time of this writing) is v2.08 and I had v2.03. Rather than uninstall, download a bunch of large patches and reinstall again I decided to try and patch the game manually to the latest version. It turns out that was the correct solution. I had to download several small, incremental patches but once finished doing the patching I was able to play without any more problems. If you're running into simiar issues with World of Warcraft and the Burning Crusade here is a link to the patch mirrors. Follow these steps for what should be a successful installation:

  • Install the original game
  • Install the expansion
  • Install the incremental patches starting with v2.0-v2.03.
Starting points will vary based on the version of the game you get after installing the expansion. Check to see what version you have before installing any patches. When launching the game you will be able to see which version you have in the title bar of the game launcher.

Updated: 2012-02-24 12:37:24 -0800